L2TP VPN Connection Issues from Windows Workstations

Incident Report for Sharp Labs of America

Resolved

We have confirmed the issue. See additional reading here: https://www.bleepingcomputer.com/news/microsoft/new-windows-kb5009543-kb5009566-updates-break-l2tp-vpn-connections/

We have removed the offending patch from our Windows Patch server, so it should not be propagated out further.

If you are still having issues, please let Chris or I know.
Cheers,
Chuck
Posted Jan 12, 2022 - 10:59 PST

Identified

We have identified the offending Microsoft Security Patch.

If you are not having an issue with the VPN, please disregard.

If you are having issues with the VPN and are on Windows 10, please do the following:

Please create a System Restore Point (Follow https://support.microsoft.com/en-us/windows/create-a-system-restore-point-77e02e2a-3298-c869-9974-ef5658ea3be9) and then remove KB5009543 from your system.

Chris and I are available if you need assistance.

We have removed this KB Update from being further propagated by our Windows Update Server.
Posted Jan 12, 2022 - 10:48 PST

Update

We are continuing to investigate this issue.
Posted Jan 12, 2022 - 08:52 PST

Investigating

We are currently investigating this issue.
Posted Jan 12, 2022 - 08:51 PST
This incident affected: SLA Production Servers (Virtual Hypervisors, Active Directory, Replicon-Time Off Manager, sftp.sharplabs.com, SLAPT-FS1) and SLA Network (PacTrust Network).